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Chapter 1: Before you begin

Preface

Program GanttViewer is designed for displaying and modifying project schedules in Gantt charts.

Gantt chart is a popular type of a bar chart that illustrates a project schedule. Gantt charts illustrate 
the start and finish dates of terminal elements and summary elements of a project. Terminal elements 
and summary elements comprise the work breakdown structure of the project. Some Gantt charts 
also show the dependency relationships between activities.

Program GanttViewer is independent on a platform. It means that it can be used on any operation 
system.

Tomas Skalicky
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Chapter 2: Start and exit

Start

Before you start program GanttViewer, JAVA SDK or JRE is needed to be install. You can download it 
on http://developers.sun.com/downloads/.

You have to execute “GanttViewer.jar” file to start program GanttViewer.

After starting the program, the main window shows. You can display and modify a project schedule in 
it.

Exit

When you want to exit from the program, all open schedules are checked whether they are saved.

Tomas Skalicky
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Chapter 3: Work area

Menu bar and toolbars

If you want to create a new schedule, switch to “Resources” pane or remove a selected task, you can 
do that using a menu bar or toolbars. There are details about them below.

| File toolbar | Tools toolbar

File

> New Schedule... If you want to create a new schedule. (See also Creating schedules  )

> Open Schedule... If you want to load a schedule from a file. (See also Opening schedules)

> Reload If you want to load the shown schedule again. You are asked whether you 
want to save unsaved changes. (See also Opening schedules)

> Close... If you want to close the shown schedule. You are asked whether you want to 
save unsaved changes. (See also Closing schedules)

> Schedule Properties If you want to change properties of the shown schedule. (See also Changing
schedule properties)

> Save If you want to save the shown schedule. (See also Saving schedules)

> Save As... If you want to choose a filename and save the shown schedule to a file with it. 
(See also Saving schedules)

> Exit If you want to exit from the program. (See also Exit)

Tomas Skalicky
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Edit

> Undo If you want to undo changes. (See also Undo and redo changes)

> Redo If you want to redo changes. (See also Undo and redo changes)

View

> Resources If you want to switch to “Resources” pane. (See also “Resources” pane)

> Tasks If you want to switch to “Tasks” pane. (See also “Tasks” pane)

Insert

> New Resource If you want to add a new resource. (See also Adding new resources)

> New Task If you want to add a new task. (See also Adding new tasks)

Task

> New If you want to create a new task. (See also Adding new tasks)

> Edit If you want to edit a focused task. (See also Editing tasks)

> Remove If you want to remove a focused task. (See also Removing tasks)

> Edit Predecessors If you want to edit predecessors of a focused task. (See also Editing task's
predecessors)

> Edit Resources If you want to edit resources of a focused task. (See also Editing task's
resources)

Tomas Skalicky
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> Edit Operations If you want to edit operations of a focused task. (See also Editing task's
operations)

Resource

> New If you want to create a new resource. (See also Adding new resources)

> Edit If you want to edit a focused resource. (See also Editing resources)

> Remove If you want to remove a focused resource. (See also Removing resources)

> Edit Tasks If you want to edit tasks of a focused resource. (See also Editing resource's
tasks)

Tools

> Reschedule If you want to reschedule the shown schedule to have a correct schedule. 
(See also Rescheduling)

Window

> [an opened file with schedule]

Tomas Skalicky
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If you want to switch to another loaded schedule.

Help

> About If you want to know some information about the program.

Tomas Skalicky



User guide for GanttViewer 9

“Tasks” and “Resources” panes

In these panes, schedules are shown. Both panes are divided into two parts: the left one is a table 
and the right one is a chart.

Tables of both panes can be sorted by all columns (Task ID, Resource ID - sorted by string values; 
Duration, Start, Finish, Allocated Time - sorted by numeric values; Predecessors, Resources, Task - 
sorted by number of values).

Both charts have time on x-axis. Imaginary units are used. The least correct value of time is 0 and 
the least difference between two values is 1. When you want to zoom in (out) a chart, you only need o 
press the left button of your mouse when your mouse is above the header of a chart and drag your 
mouse to the right (left). Values in cells of the header will change when cells' widths are big or small 
enough. Number of cells is fixed.

Default view

Zoomed out view

“Tasks” pane

In the table, there are shown all tasks and details about them. All columns are editable.

In the chart, there are images of tasks and images of dependencies between tasks. Images of 
tasks are next to rows of the table with details about the tasks.

If you want to move an image of a task, press the left button of your mouse when your mouse is 
above the image and drag your mouse where you want to place the image.

If you want to resize an image of a task, press the left button of your mouse when your mouse is 
above the left or the right side of the image and drag your mouse.

See also Editing tasks

Tomas Skalicky
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“Resources” pane

In the table, there are shown all resources and details about them. “Allocated Time” represents how 
long a resource is allocated for doing its tasks. All columns except “Allocated Time” are editable.

In the chart, there are images of tasks. No images of dependencies are there. Images of tasks are 
next to rows of the table with details about resources which are allocated for doing the tasks. It means 
that if a task is planned to be done by two resources, there is an image of the task next to the first 
resource and an image next to the second one.

You can move and resize images of tasks as in “Tasks” pane.

If you want to move a task from one resource to another, press the left button of your mouse when 
your mouse is above the image of the task and drag it above the second resource.

See also Editing resources

Tomas Skalicky
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Chapter 4: Creating, opening, closing and saving schedules

Creating schedules

If you want to create a new schedule, click on File > New Schedule... or New Schedule... in “File 
toolbar” or type Ctrl+N.

The new schedule has an ID in the form “Unknown-[number]” where “[number]” is the first free 
number of schedules with not specified ID.

Opening schedules

If you want to load a schedule from a file, click on File > Open Schedule... or Open Schedule... in “File 
toolbar” or type Ctrl+O. If you want to load the shown schedule again, click on File > Reload or 
Reload current schedule in “File toolbar” or type F5.

The input file has to be a text file and have a fixed format (TXT format or XML format).

TXT format

Lines which begins with '#' character are comments. On the first line which is not comment, there is 
an ID of a schedule. Other lines which are not comments represents tasks. Each line is divided into 
cells by tabulators and in these cells, there are TaskID, OrderID, ProductID, PartsIDs, Start, Finish, 
PredecessorsIDs, ResourcesIDs in this order.

TaskID   . . . . . . . . . . an ID of a task

OrderID   . . . . . . . . . an ID of an order

ProductID   . . . . . . . . an ID of a product

PartsIDs   . . . . . . . . . IDs of operations which needs to be done during carrying out of the task

Start   . . . . . . . . . . . . time when it is planned the beginning of carrying out of the task

Finish   . . . . . . . . . . . time when the task is planned to be finished

PredecessorsIDs   . . IDs of tasks which need to be finished before carrying out of the task begins

ResourcesIDs   . . . . IDs of resources which is allocated for carrying out of the task

In PartsIDs, PredecessorsIDs and ResourcesIDs, there are values divided by ',' character.

Tomas Skalicky
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ScheduleID
TaskID      OrderID      ProductID      PartID,...,PartID      Start      Finish      PredecessorID,...,PredecessorID
ResourceID,...,ResourceID
...
TaskID      OrderID      ProductID      PartID,...,PartID      Start      Finish      PredecessorID,...,PredecessorID
ResourceID,...,ResourceID

XML format

There is a definition of XML format in XML Scheme below.

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">

<xs:element name="Schedule">
<xs:complexType>

<xs:sequence>
<xs:element name="ScheduleID" type="xs:string" />
<xs:element name="Tasks">

<xs:complexType>
<xs:sequence>

<xs:element ref="Task" minOccurs="0" maxOccurs="unbounded" />
</xs:sequence>

</xs:complexType>
</xs:element>

</xs:sequence>
</xs:complexType>

</xs:element>

<xs:element name="Task">
<xs:complexType>

<xs:sequence>
<xs:element ref="TaskID" />
<xs:element name="OrderID" type="xs:string" />
<xs:element name="ProductID" type="xs:string" />
<xs:element name="Parts">

<xs:complexType>
<xs:sequence>

<xs:element name="PartID" type="xs:string" />
</xs:sequence>

</xs:complexType>
</xs:element>
<xs:element name="Start">

<xs:complexType>
<xs:sequence>

<xs:element ref="Value" />
</xs:sequence>

</xs:complexType>
</xs:element>
<xs:element name="Finish">

<xs:complexType>
<xs:sequence>

<xs:element ref="Value" />
</xs:sequence>

</xs:complexType>
</xs:element>
<xs:element name="Predecessors">

<xs:complexType>
<xs:sequence>

<xs:element ref="TaskID" />
</xs:sequence>

</xs:complexType>

Tomas Skalicky
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</xs:element>
<xs:element name="Resources">

<xs:complexType>
<xs:sequence>

<xs:element name="ResourceID" type="xs:string" />
</xs:sequence>

</xs:complexType>
</xs:element>

</xs:sequence>
</xs:complexType>

</xs:element>

<xs:element name="TaskID" type="xs:string" />

<xs:element name="Value" type="xs:integer" />
</xs:schema>

If the input file is not in a correct format, “Input errors” dialog will show details about errors. Schedule 
which is in that file will be loaded without data with errors.

Closing schedules

If you want to close the shown schedule, click on File > Close... or type Ctrl+W.

You are asked whether you want to save unsaved changes.

Saving schedules

If you want to save the shown schedule, click on File > Save or Save in “File toolbar” or type Ctrl+S. If 

Tomas Skalicky
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you want to choose a filename and save the shown schedule to a file with it, click on File > Save As....

You can save a schedule in TXT format or XML format.

Tomas Skalicky
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Chapter 5: Modifying schedules

Undo and redo changes

If you add or remove a task or a resource, you can undo it by clicking on Edit > Undo or typing Ctrl+Z.

If you have used undo function last time, you can redo the last change by clicking on Edit > Redo or 
typing Ctrl+Y.

Changing schedule properties

If you want to change properties of the shown schedule, click on File > Schedule Properties. After 
that, “Schedule Properties” dialog will display.

In it, you can change an ID of the schedule.

Adding new tasks

If you want to add a new task, click on Insert > New Task, Task > New or New Task in a popup menu 
which is above the table of “Tasks” pane or in “Tasks” and “Predecessors” dialog, you can use “New 
Task” button. After any of these possibilities, dialog “New Task” will display.

In it, you can set details of the new task. (See also Editing tasks)

Tomas Skalicky
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Editing tasks

If you want to edit a focused task, click on Task > Edit or Edit Task in a popup menu which is above 
the table of “Tasks” pane. After any of these possibilities, dialog “Edit Task” will display.

In it, you can change details of the focused task.

Task ID   . . . . . . . . . . an ID of the focused task

Order ID   . . . . . . . . . an ID of an order

Product ID   . . . . . . . . an ID of a product

Tomas Skalicky
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Operations   . . . . . . . IDs of operations which needs to be done during carrying out of the task (See 
also Editing task's operations)

Start   . . . . . . . . . . . . time when it is planned the beginning of carrying out of the task

Finish   . . . . . . . . . . . time when the task is planned to be finished

Predecessors   . . . . . IDs of tasks which need to be finished before carrying out of the task begins 
(See also Editing task's predecessors)

Resources   . . . . . . . IDs of resources which is allocated for carrying out of the task (See also 
Editing task's resources)

If you only want to change values of time, you can move or resize an image of the task in any chart. 
(See also “Tasks” pane, “Resources” pane)

Editing task's predecessors

If you want to change predecessors of a focused task, click on Task > Edit Predecessors. After that, 
“Predecessors” dialog will display.

In it, you can select tasks, which will be predecessors of the focused task.

Editing task's resources

If you want to change resources of a focused task, click on Task > Edit Resources. After that, 
“Resources” dialog will display.

Tomas Skalicky
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In it, you can select resources, which will be allocated for carrying out the focused task.

Editing task's operations

If you want to change operations of a focused task, click on Task > Edit Operations. After that, 
“Operations” dialog will display.

In it, you can modify operations, which will be done during carrying out the focused task.

Tomas Skalicky
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Removing tasks

If you want to remove a focused task, click on Task > Remove or Remove Task in a popup menu 
which is above the table of “Tasks” pane or type Ctrl+D.

Adding new resources

If you want to add a new resource, click on Insert > New Resource, Resource > New or New 
Resource in a popup menu which is above the table of “Resources” pane or in “Resources” dialog, 
you can use “New Resource” button. After any of these possibilities, dialog “New Resource” will 
display.

In it, you can set details of the new resource. (See also Editing resources)

Editing resources

If you want to edit a focused resource, click on Resource > Edit or Edit Resource in a popup menu 
which is above the table of “Resources” pane. After any of these possibilities, dialog “Edit Resource” 
will display.

In it, you can change details of the focused resource.

Resource ID   . . . . . . an ID of the focused resource

Tasks   . . . . . . . . . . . IDs of tasks which are carried out by the resource (See also Editing
resource's tasks)

Tomas Skalicky
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Editing resource's tasks

If you want to change tasks of a focused resource, click on Resource > Edit Tasks. After that, “Tasks” 
dialog will display.

In it, you can select tasks, which will be carried out by the focused resource.

Removing resources

If you want to remove a focused resource, click on Resource > Remove or Remove Resource in a 
popup menu which is above the table of “Resources” pane or type Ctrl+D.

Tomas Skalicky
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Chapter 5: Rescheduling

Rescheduling

If you want to have a correct schedule, you can use rescheduling function.

Schedule is correct whether:

no task begins earlier than all its' predecessors finish,

each resource carry out up to one task at a time.

Conflicts are solved locally. It means that tasks are shifted as few as possible.
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